Share:
Notifications
Clear all

Kikusui 5520 Scope

 
Alastair
(@alastair)
Reputable V-Ratter Registered

On my travels today I came across this 20Mhz dual-channel Scope. It was a little dented but looked in reasonable state--so I grabbed it,--As you do...

It was a little wet externally but internally seemed fairly dry. I let a fan-heater run into the open case for an hour or so to be sure.

Fired it up--and it worked! Good strong sharp trace both channels alive and trig sync working, but very noisy switches, so decided to leave it run for a while, the was going to remove the CRT to gain access to the various switches to give 'em a spray with switch-cleaner....

It ran for about half hour or so, then the trace suddenly went off.....

I checked various things, tube heaters still lit, 1950V at this test-point present etc --all rails that are actually marked are there and correct.
Turning the Focus to one end to prevent tube damage I shorted Cathode to G1 and saw that the horiz timebase isnt working.
There is a nice bright well-defocussed blob at the far right of the screen that responds slightly to the horiz position pot but not much else!.

Cant find any info on this Japanese Scope from the early 80's.....

Any ideas...?

ReplyQuote
Topic starter Posted : 28/05/2013 11:27 pm
GlowingAnode
(@glowinganode)
Reputable V-Ratter Deactivated Account

Hi Al, what a lucky find. These are super little scopes and give a good trace.
Sounds like it's not triggering. Try in a different trigger mode, NORM or LINE.
Also try in X-Y mode, this should establish whether it's a TB or Y amp fault.
Will try and dig out a manual.
Cheers,
Rob.

Thursday night is shed night.

ReplyQuote
Posted : 29/05/2013 1:03 am
Alastair
(@alastair)
Reputable V-Ratter Registered

Hi Rob!

Really appreciate the input....

Guess thats the only thing I didn't try was in X-Y mode....Will give that a try later.
--Tried most other stuff--nothing doing.

Ive not heard of this make before, seems reasonably well put together, just a shame it quit like it did!

If you could find a schematic--that would be magic! Ive not worked on many scopes, there seems to be just hundreds of transistors in this thing--I'm guessing one has popped......

ReplyQuote
Topic starter Posted : 29/05/2013 12:27 pm
Anonymous
(@anonymous)
Illustrious V-Ratter Deactivated Account

The fact that the screen was blank does sound like a TB or trig fault. Your scope will have a trace unblanking circuit attached to the brightness circuitry. The screen will remain blank until a sweep starts. Since you say that the switches are noisy I would start fault finding there. You could even start 'buzzing' them out without having to refer to the schematic.

Al

ReplyQuote
Posted : 29/05/2013 12:44 pm
Mark Hennessy
(@markh)
Reputable V-Ratter Registered

Another thumbs-up for Kikusui 'scopes - we have a lot of COS5020 and similar models at work. They have spent the last ~30 years in our Funds labs, where they've been hammered by new BBC engineers who have been learning about electronics. They've lasted remarkably well, given that they are built to pretty basic standards compared to the "big names".

But - and it's a big "but" as far as I'm concerned - we don't have any service data for them. And so far, I've failed to find any on-line. For that reason, I've never brought one home when the opportunities presented themselves - not that I need another 'scope! As you might imagine, we've had a fair few shrinkages over the years, and each time, we've re-homed the spare 'scopes with local schools or keen engineers who we thought would make good use of them - in my time here, none of them have gone into the skip!

But I digress. Essentially, you're probably on your own with this. It sounds like all the tricky stuff (EHT, PSUs) is working, and it might be a simple switch (try the single-shot switch) or connector problem. Or perhaps the X output amplifier or sweep generator? Have you another 'scope to check around?

Good luck :thumbl:

Mark

ReplyQuote
Posted : 29/05/2013 12:47 pm
sideband
(@sideband)
Famed V-Ratter Moderator

It's a good idea to check any connectors that may be present linking one board to another before getting more technical. If it's been damp, one or more of these could be dodgy sometimes requiring nothing more than pull-out and reconnect to remove any tarnish.

Eliminate these first before diving in to what could be quite complex circuitry.

Rich.

ReplyQuote
Posted : 29/05/2013 2:38 pm
peterscott
(@peterscott)
Prominent V-Ratter Registered

Hi Alastair,

I have a 5040 and couldn't find any service manual for it but I have the Operating Manual. If it's any use to you then PM your email address and I send you a copy.

Peter

www.nostalgiatech.co.uk

ReplyQuote
Posted : 01/06/2013 1:05 pm