Featured
Latest
Farnell SSG520 synt...
 
Share:
Notifications
Clear all

Forum 141

Farnell SSG520 synthesised signal generator

4 Posts
3 Users
1 Reactions
718 Views
Niall
(@niall)
Posts: 458
Honorable Member Registered
Topic starter
 

I know I've been away from the forum for a while, for personal reasons I have only recently felt like venturing into the workshop.

I have been after a decent sig gen for a while and finally got this one at the Newark hamfest last year. Supposed to be working, although at the price I doubted that, and certainly when plugged in it lit up and the output level meter varied with the appropriate control.  Back home it was apparent there was in fact no RF output so I downloaded the service manual from here:  https://www.opweb.de/en/model.php?id=13710 and got it on the bench.

First problem was a missing 24V rail. This came back up when the "amplitude modulator and output amp" board was disconnected from the rail. This board sported a prominent blue tant across the 24 v rail, remembering the admonitions of LLJ I replaced it with an electrolytic and the issue was solved.

There was still no output, this was traced to a lack of power to the appropriate VCO. This is derived from the frequency selection thumbwheels and encoded to 4 bit BCD which wasn't happening due to a faulty CMOS counter, IC4 on the control board. When replaced the lock LED behaved correctly and output could be obtained, although the level was low and while the coarse attenuator worked the fine level controls were ineffective.

There was an anomaly with the operation of the frequency thumbwheel controlling the 100 kHz steps but fortunately this responded to Servisol.

I have traced the output level issue to the AM and output board and particularly IC1 (CA3130) and associated circuitry but I would appreciate some help here.

Fault is as follows:

With the RF box cover withdrawn, fine attenuator and level control at maximum, touching or probing the pin 1 -4 side of the 3130 brings up the expected output, it can be turned down so far then the output collapses to a very low level and does not recover when the level is turned back up until the 3130 is touched or probed again.

The 3130 is socketed so I set up a breadboard voltage follower circuit to test it, this does not behave as I expected. When the input is varied from + to - supply (using a split supply) the output does not go negative until the input is several volts negative. A 741 in the same circuit behaves as expected, the output follows the input.

I bought a new 3130 from a reputable supplier, this behaves the same in the test circuit. In the sig gen it behaves the same as the old 3130 except that a finger anywhere in the vicinity of the IC is enough to start it, and closing the RF box cover makes the output collapse as soon as it covers the IC.

A 741 fitted in place of the 3130 produces a slightly reduced output (approx. 0.7 v p-p against 1V p-p with the 3130), with the 741 the level control has no effect.

Starting with the level controls at maximum and the circuit provoked into operation then turning down the output level control, the voltages around the 313o are as follows:

Pin 2: 8.99 V falling to 8.4 V then when output fails goes to 9.22 V

Pin 3: 8.9 V falling to 7.8 V then output fails

Pin 6: 3.1 V falling to 2.5 V then when output fails goes to 0V.

I'm wondering if it's worth trying another 3130?

I have tested the following components as OK:

C 16, 23, 25

R38, 33, 34

R29 can't check as shunted by C25/R38 but shows around 4M which seems plausible.

The track side of this board isn't accessible without major dismantling.

 

 

 

 

 
Posted : 16/02/2019 6:07 pm
MurphyV310
(@murphyv310)
Posts: 457
Honorable Member Registered
 

Hi.

Did you ever get to the bottom of this. I have a SSG 520 and its multi faulted so I'm reading through all the threads on as many platforms about faults and cures.

Cheers,
Trevor.
MM0KJJ. RSGB, GQRP, WACRAL, K&LARC. Member

 
Posted : 03/10/2022 5:03 pm
peterscott
(@peterscott)
Posts: 1028
Honorable Member Registered
 

Hi Trevor,

I'm fairly sure that the main problem is in the prescaler. Unfortunately access requires you to unsolder its lid but it's too hard to do.

Peter

www.nostalgiatech.co.uk

 
Posted : 03/10/2022 7:00 pm
MurphyV310
(@murphyv310)
Posts: 457
Honorable Member Registered
 

Hi Peter.

Thanks for the reply, I've actually a thread on the UKVRRR (sorry Chris) here https://www.vintage-radio.net/forum/showthread.php?p=1503262#post1503262

Ive had some success tonight and as far as I can see its either the cabling from the thumb wheels or the corresponding edge connector. The main problem was the cabling from the PSU there seems to be a reaction from the tape and the OVC cables causing a reaction and going all gooey giving a rise to a short on the 15v line.

I'm getting there as at one point I had it working by putting pressure on the wires from the thumb wheels to the edge connector. All good fun but having rather short thick fingers don't help! 

Cheers,
Trevor.
MM0KJJ. RSGB, GQRP, WACRAL, K&LARC. Member

 
Posted : 03/10/2022 9:26 pm
peterscott reacted
Share: