Share:
Notifications
Clear all

Roberts Automatic Clock Radio CR2001  

Page 2 / 2
 
Cathovisor
(@cathovisor)
Illustrious V-Ratter Registered

I have one of the original RD1s, which I swear is a Sangean in disguise.

ReplyQuote
Posted : 26/04/2014 10:29 pm
Paul_RK
(@paul_rk)
Reputable V-Ratter Registered
Posted by: @cathovisor

I have one of the original RD1s, which I swear is a Sangean in disguise.

Not much doubt about that. A Google image search for 'Sangean Radio' shows most of Roberts' range of sets from the past ten years and longer, aside from a little cosmetic tweaking which hides nothing.

Paul

ReplyQuote
Posted : 26/04/2014 11:42 pm
Anonymous
(@anonymous)
Illustrious V-Ratter No longer Member

The clock started to work over night and I tested the alarm this morning, still the same, stuttering on and off when the alarm goes off, maybe it was on for longer in between going off. Give up time I think to clear the bench for next project.

ReplyQuote
Posted : 27/04/2014 10:24 am
Mkstevo
(@mkstevo)
Busy V-Ratter Registered

It's been a while since this was updated I know, but I thought I'd add my experience to the thread. It may help someone out in the future. I bought one of these recently in an online auction for 99p plus £3.99 P&P. It was sold as being unable to set the alarm, but I'd assumed this meant that the alarm could not be set, not that once set, the alarm didn't come on. The seller had packed it very badly and it arrived with the dial perspex broken, the hands of the clock so loose they didn't turn on the spindle, the wooden case gouged by the plug and the speaker broken or twisted which severely distorted the sound.

I put the hands back on the clock first, making the hour and minute hands grip the spindle with a small amount of masking tape. Plugged in and waited for the hands to stop rotating, unplugged again then aligned them all to 12 o'clock.Plugged in again and waited for the time to be set. Unplugged, set the hands to the correct time, plugged in again, checked that the hands returned to show the correct time and set the alarm. The alarm time came and went. Nothing. Looked at the control PCB and gave up. I glued the dial back together, replaced the speaker and went to bed. Still nothing from the alarm. I wondered if I'd got the alarm hand misaligned but after 24 hours the alarm still didn't work. I was determined I wasn't going to get beaten so had another look. I found that if I measured a voltage on one transistor on the "radio" board when it was in the alarm position, the radio would be activated just by putting a DMM probe on it. Tracing this back to the control board and again on that board, if I touched a 10k resistor (possibly R53) on the control board, the radio would indeed come on. Tracing the path back from this led me nowhere. I decided to approach it from another angle. I desoldered one of the piezo units and soldered it to the shielded connections from the clock unit. Waited for the alarm time and I could just hear a "beep... beep... beep..." from the piezo. I started to think I was at last getting somewhere. Tracing the signal from this led me to a point that I could apply bias which would activate either alarm or radio, depending on the position of the switch. I still couldn't see why it wasn't working automatically though, everything seemed to be working. But it didn't work. I then began to think about how the circuit might be expected to work. I wondered if the connection to the clock module (where I had soldered the piezo to) that was labelled as "col" indicated it went to an open collector output on the clock module? There was no voltage on this part of the circuit at all. Tracing this path led me to a radial inductor with 1.8V one side and zero on the other. I looked closely at this inductor for any markings but found nothing. I could see some verdigris deposits on it though which confirmed my diagnosis that it had corroded and gone open circuit. As it seemed to provide some bias for the buzzer output on the clock module I tried replacing it with a 1k5 resistor in the hope I'd get enough drive for the rest of the circuit. With the 1k5 in place the alarm does indeed work.

It would seem that part of the task of the control circuit is to amplify and rectify the 1kHz "beep" from the clock module, then use that to activate the radio or beeper circuit on the control board, rather than just using the beep output from the clock directly. The control board seems way over complicated for what it does, I'm sure there was a reason for it being so complicated, but can't for the life of me think what that reason was. As I don't have access to the circuit diagram, I don't know whether there is any point fitting a replacement inductor, as the alarm does now work, possibly not. The alarm does however have a quirk. About 1 minute or so before the alarm comes on, there is a crackle of noise for no more than 100mS from the radio, then nothing before the radio comes on. This could be not having an inductor but a 1k5, or it could be normal for this (in my opinion) shockingly bad design.

Mr Roberts would weep to see such a horribly made thing bearing his name. It truly is awful. It was only that I was determined not to be beaten that I persisted. Still, I've cleaned the case, replaced the speaker, fixed the clock, repaired the alarm and put the dial together. Much more importantly, I wasn't beaten!

ReplyQuote
Posted : 18/05/2020 9:37 pm
Page 2 / 2